Webinar: Introducing the NEW PaintShop Pro 2018!

Webinar: Introducing the NEW PaintShop Pro 2018!

By the Photo Team

Welcome to the NEW PaintShop Pro 2018! Join us for this 30-minute webinar as we give you a tour of the exciting new features and enhancements. Get a tour of the new Essentials workspace and Welcome Screen, see the new color palettes, gradients, patterns and textures in the Materials palette, and the 30 new brushes in the Brush library.

In the second half of the webinar, PaintShop Professional Brad Barton demonstrates the enhancements to the crop tool, clone brush, dropper tool and gradient fill tool.

Thanks for watching! We hope you found this tutorial helpful and we would love to hear your feedback in the Comments section below. And don’t forget to visit our social media pages and show us what you’ve learned by sharing your photos, videos and creative projects with us.

See what's new in PaintShop Pro 2019!

Download your FREE 30-day trial and check out the latest version of PaintShop Pro, with new creative content, artistic presets and 360° photo editing tools plus dozens of performance improvements for faster photo editing.


Related Tutorials


Tools You Need

PaintShop Pro 2019

PaintShop® Pro 2019 is your affordable, professional photo editor designed by passionate photo enthusiasts.

Rainy Day Script

Add a realistic rain effect to your photos without getting your camera wet using the Rainy Day script for PaintShop Pro.

PaintShop Pro 2019 Ultimate

Get the full photo-editing power of PaintShop Pro 2019 plus an exclusive bonus collection of premium photo software.

Split Tone Script Bundle

This collection of 5 split tone scripts will add different colors to shadows and highlights in your photos for dramatic results!


Related Images

Share this post

Comments (16)

  • karen kenealy Reply

    I really would rater have a manual that i could take my time and highlight sections i want to go over again…hard to follow the tutorials…

    September 16, 2018 at 1:56 pm
    • gilliandarby Reply

      Hi Karen,

      Under the Help menu in PaintShop Pro, you can download a PDF copy of the User Guide manual.

      Hope this helps,

      The Discovery Center team

      September 16, 2018 at 2:43 pm
  • John Reply

    The video tutorials are way too small and way to fast. Is there a printed version available? If not and you can’t improve the video’s then the program is not for me

    March 19, 2018 at 12:03 pm
    • Adam Reply

      Hello John,

      Thank you for the feedback! We are always looking for ways to improve the accessibility of our tutorial content, and will pass your suggestions on to our tutorial team.

      While not all of our tutorials have written instructions to go along with them at this time, we are always adding to our written and video tutorial content.

      As for the size, you can enlarge any of our tutorial videos to full screen using the button in the lower right of the video player, while the video is playing.

      Hope this helps!

      Discovery Center Team

      March 19, 2018 at 10:07 pm
  • debbiej Reply

    I have upgraded from X9 to 2018 Ultimate, I cant seem to get my plugins to work. Do I need to uninstall X9 in order for them to transfer to 2018? My particle shop wont even show up. Thanks

    March 4, 2018 at 4:17 pm
    • Adam Reply

      Hello Debbie,

      All you need to do is tell PSP 2018 where the plugin folder for X9 is! Here is a tutorial on installing plugins in PaintShop Pro that goes through how to add an additional plugin folder.

      Discovery Center Team

      March 4, 2018 at 6:01 pm
  • Bonnie Reply

    I just purchased the Pro 2018 Ult. This video was useless to me. I have no idea what they were clicking on. This video is meant for people who already use this software. I have no idea how to do anything with this software. I am a full time Pro Photographer since 1985, graduated from an Art Institute in 1993. How and where do I learn how to use this software?

    February 14, 2018 at 4:27 pm
  • Juan Casero Reply

    I really like Corel’s products. They have really come a very long way since the days they purchased WordPerfect and really for the better. I purchased your entire suite of media products from AfterShot Pro to VideoStudio Ultimate, to PaintShop Pro Ultimate. In my opinion they represent a good value proposition not just for enthusiasts and prosumers but also for professional artists. As long as you guys keep improving the products and keep improving the value proposition you can count on my continued patronage!

    December 25, 2017 at 2:03 pm
    • Michael A Parkes Reply

      I’m in the same boat. Was going to switch from Photoshop but now I’m not so sure.

      February 27, 2018 at 2:00 pm
  • Alan Puzey Reply

    Overall a 50/50 presentation. The best part was when Brad got into demonstrating some of Paintshop’s new features. The rest came over as too unrehearsed with too many advertising references. It was fast in places, but no problem as one can pause it and re-evaluate. This introduction video should be remade more professionally. I look forward to seeing some of the other, more specific video tutorials.

    I have been a user since the Jasc days and indeed still find Jasc version 9 a better and faster way of doing things than many of the modern programs – but I have purchased Paintshop Pro 2018 and it looks better than most of the intermediate versions of the past.

    December 23, 2017 at 12:20 am
  • Gail Reply

    This tutorial to introduce the software goes to fast and the cursor is going all around that my eyes could not keep up and I had to keep pausing and going back. Maybe highlight the cursor so it is easier to follow and slow down.

    December 14, 2017 at 6:06 pm
  • Patricia Temple Reply

    how do I make a photo look like a painting please

    December 8, 2017 at 5:47 am
    • gilliandarby Reply

      Hi Patricia,
      In the top menu bar, choose Effects > Art Media Effects > Brush Strokes. In the Brush Strokes window that will open, you have different settings you can adjust to get the look you want.

      For some images, I find this effect blurs out some of the small details I want to keep, for example eyes in a portrait image. So before I apply the painting effect, I duplicate my image in the layers palette, then apply the effect on the duplicate layer. Then you can use the eraser tool to gently erase some of the painting layer to bring back details of the photo below.

      Hope this helps! You can also find other artistic effects in the Instant Effects palette. Go to View > Palettes > Instant Effects to open it. From the drop-down list at the top, select the Artistic category and you will see Charcoal, Pencil etc.

      December 8, 2017 at 10:10 am
  • Erlene Reply

    Whoa slow down please!! The women is talking so fast that I can not understand what she is saying. It might be a good tutorial but you have to be able to hear it properly. I know Americans talk fast but just remember that this product is going all over the world and maybe you should consider that before you put together a video. I am now looking for the printed version of it so that I can work myself through.

    December 5, 2017 at 2:39 pm
    • Adam Reply

      Hello Erlene,

      Thank you for your feedback! We have passed it on to our tutorial creators for their consideration.

      Corel Discovery Center Team

      December 9, 2017 at 12:11 am
  • Kathy Porter Reply

    Thank you for this wonderful Tutorial! I am excited to see so many great new features. Thank you

    November 29, 2017 at 4:51 pm

Leave a Reply

Your email address will not be published. Required fields are marked *


Sign-up for our newsletter

Sign-up for our newsletter

Get our latest tips, tutorials, and special offers sent weekly to your inbox!

You have Successfully Subscribed!

Pin It on Pinterest

Share This