Creating Video and Text Masks in VideoStudio

Creating Video and Text Masks in VideoStudio

VideoStudio Ultimate 2019 introduces new Text Masks! Jump in and get creative with new video mask possibilities. Create text masks, a cool way to add a title or scene transition and have your video playing behind it.

How to create a still mask or text mask with the Mask Creator

  1. In the Timeline view (Edit workspace), select the clip you want to work with, and click the Mask Creator button on the Timeline toolbar.
  2. In the Mask Creator window, click the Still option.
  3. In the Tools area, choose one of the following: Mask Brush, Smart Mask Brush, Rectangle tool, Ellipse tool, Freehand tool or Text Mask.
  4. In the Playback window, drag, draw, or type to select a mask area. A highlight appears over the selected area.
  5. You can fine-tune the mask by using the tools to modify the selected area.
    • To reset the mask, click the Clear Mask button.
    • If you want to invert the mask, in the Save options area, click the Invert mask option.
    • If you want to save the mask as a Mask Frame (Options panel, Effect > Apply Overlay
      Options > Mask Frame), click Save As and type a name for your PNG mask.
  6. Click OK to exit Mask Creator. The mask appears on its own track in the Timeline, below the original source clip. You can adjust the length of the mask as you would other clips and you can apply effects to the mask by dragging an effect onto the mask in the Timeline. You can also change the clip for the mask by dragging a new clip from the Library to the masked clip and pressing CTRL.

To save a mask

  1. After you create a mask, in the Save options area of the Mask Creator dialog box, click Mask (default) or Invert mask. Note: If you invert the mask, the Preview area does not show the inverted mask—it displays when you return to the Timeline.
  2. Set a destination in the Save to box.
  3. Click the Save As button at the bottom of the dialog box, and choose a name for the mask.

If you want to link the mask to the original clip, mark the Link mask to source clip check box. Note that you can link only one mask per file.

To import a video or still mask as an overlay option

  1. In the Timeline, select an overlay clip.
  2. In the Options panel, click Effect tab
  3. Enable the Apply Overlay Options check box, then choose Mask Frame (for a still mask) or Video Mask from the Type drop-list.
  4. Click the Add mask item(s) button to the right of the mask preview area, and browse to a saved mask file (.uisx format for a video mask, .png for a still mask). The mask is added to the preview area.

See what's new in VideoStudio 2021!

Download a FREE 30-day trial and check out the streamlined tools plus new AR Stickers, Instant Project Templates and creative extras that make it fun and easy to create impressive movies.


Related Tutorials


Tools You Need

VideoStudio Pro 2021

VideoStudio Pro 2021 makes it fun and easy to create impressive videos, with hundreds of drag and drop filters and effects plus new templates and AR stickers.

Animated Filmstrip Transitions

Use these 15 filmstrip animations with sound FX as moving scene changes in between clips to give your video a fast, modern look.

VideoStudio Ultimate 2021

Turn your best moments into unique movies with the streamlined tools, premium effects and new creative extras in VideoStudio Ultimate 2021.

Falling Rain Overlays

Add a realistic falling rain effect to your VideoStudio projects with this collection of 4 animated overlays.

Share this post

Leave a Reply

Your email address will not be published. Required fields are marked *


Get a FREE creative pack!

Get a FREE creative pack!

Sign up for our newsletter and get a free creative pack plus the latest tips, tutorials, and special offers in your inbox each week.

You have successfully subscribed! Check your inbox for your email confirmation and free creative content pack.