10 Tips for Better CorelDRAW Productivity

10 Tips for Better CorelDRAW Productivity

Want to simplify the design process and speed up your workflow? Check out these top 10 CorelDRAW tips that will help you increase your productivity. These hidden gems from our CorelDRAW experts may surprise even the most experienced user!

Thanks for watching! We hope you found this tutorial helpful and we would love to hear your feedback in the Comments section below. You will find a written version of this tutorial below, and a printable PDF copy to download from the Download Resources tab above.

Want to simplify the design process and speed up your workflow? Check out these top 10 CorelDRAW tips that will help you increase your productivity. These hidden gems from our CorelDRAW experts may surprise even the most experienced user!

Thanks for watching! We hope you found this tutorial helpful and we would love to hear your feedback in the Comments section below.

See what's new in CorelDRAW Graphics Suite 2019!

Download your FREE 15-day trial for Windows or Mac and dare to design differently with new non-destructive effects, improved pixel workflow, and other professional graphics tools.

Now is your last chance to upgrade to CorelDRAW Graphics Suite 2019

Later this year, upgrades will no longer be available. Upgrade today and find all the professional graphic design tools you need to work faster, smarter, and in more places—including on the go with CorelDRAW.app™.

Learn More

Tools You Need

CorelDRAW Graphics Suite 2019

Get all the professional graphics tools you need to work on Windows, Mac or on the go with CorelDRAW.app.

Comic Book Word Art

Make yourself and your friends the superheroes (or villains) in a comic book with collection of 80 word art images.

CorelDRAW Home & Student Suite 2019

A complete design suite for home and students. Edit photos and create reports, drawings, flyers, ads, business cards, logos and more.

Wacom Intuos Pro Medium

With plenty of room to sketch, paint and design, this medium-sized tablet is a popular choice for artists and designers.


10 Tips for Better Productivity in CorelDRAW

Do you know how to quickly create a frame around an image? Or how to align objects with a single keystroke? Check out these 10 CorelDRAW productivity tips, which may surprise even the most experienced users.

Click on any of the images below to view full-size.

Tip 1: Creating Complex Shapes with the Polygon Tool

The Polygon tool is great for making, well, polygons. Here’s a simple pentagon, and you can hold the Ctrl key to constrain its aspect ratio. Activate the Shape tool and click and drag one of the nodes. If you keep Ctrl pressed again, you can drag out a nice, even star.

Without Ctrl pressed, you can twist things around. When you pull a handle all the way to the other side, you can get some very interesting shapes.

And it gets even better when you start with a polygon with more sides. Double-click to add a node along any segment; whatever change you make to this new node happens at all the other points as well.

Making these nodes smooth, adding more nodes, and adjusting control handles, makes for even more possibilities.

And these shapes are quite fun to color with the Smart Fill tool.

Tip 2: Easy Alignment

The Object > Align and Distribute menu lists all the shortcuts for the various alignment commands: L for Align Left, R for Right, etc.

It’s easy to use these on selected objects. Press T to align tops, or B to align bottom. The last object selected stays in place, and the others move accordingly.

With the objects arranged vertically, you can use C to align centers horizontally, and P centers to the page. You can also group objects before aligning if desired.

Tip 3: Transform Docker

The Transform docker goes beyond simply moving or rotating objects. With an object selected, you can change its position, such as moving it 1” to the right and 1.5” up, then clicking Apply.

To get three of these objects spaced 3” apart, change X to 3, Y to 0, add 2 copies, and click Apply.

For rotating, try rotating 45 degrees about the center, or make 7 copies about the top point.

You can also mirror, or mirror copy. There are similar options for sizing and skewing.

You can also repeat operations, such as creating one copy at a time by clicking Apply repeatedly.

Tip 4: CorelDRAW Does the Math for You!

If you don’t feel like grabbing your calculator, let CorelDRAW do the math for you. For the rectangle in this example, here are its dimensions, and the document units are in inches.

It’s easy to change a dimension to a clean number like 3”. But you could also enter a complex value like 3 3/16”, by entering 3+3/16.

Or you can switch units, such as entering 1200 px or 75 mm. The unit conversion is done automatically.

One use of this is creating scaled objects. Let’s make another rectangle exactly ⅓ as wide as this one. To do this, duplicate the rectangle, and enter “/3” at the end of one of its dimensions to divide the value by three.

You can also do math in the Position fields! Let’s move the selected rectangle another 100mm to the right by typing “+100mm” into the X position field.

You can enter math symbols or units wherever there is a numerical field. For example, in the Transform docker, you can make a copy that’s 325 px * 3 to the right, by adding that “*3” to the X coordinate in the docker.

Tip 5: Navigator and Nano-Preview

If you’re zoomed in while working on one small part of a document and want to move to another part, you don’t have to zoom out and back in again. Click the Navigator icon at the lower right.

Keep the mouse button pressed and drag to the new spot you want to work on. Or, you can press the N key to open the Nano-Preview, where you can click a new spot.

To zoom back out, press F4 to see everything, including objects off the page. Pressing Shift + F4, or double-clicking the Zoom tool, zooms to just the page.

Tip 6: Easy Access to Frequently Used Commands

If there is a command you use all the time, you don’t have to always go to the menu for it. For example, if you want easy access to the document grid, go to View > Grid > Document Grid.

While pressing Ctrl + Alt, drag this command onto the workspace, or onto an existing toolbar. Now you can click the icon to turn the grid on and off!

To remove the icon, press Alt while dragging it away.

Tip 7: Create a Custom Color Palette

You can easily create a color palette from colors in a document. At the bottom of the Palettes docker, click the plus sign and choose New Palette from the Document.

In this example, the new palette was named Photo. Now this palette appears under My Palettes, and the palette itself is displayed vertically to the right.

Tip 8: Add a Quick Frame or Border

To put a simple frame or border around any rectangular shape, first select the object. Then press Shift while double-clicking the Rectangle tool.

This adds an outline, whose width and style and color you can adjust in the Properties docker. For the color, you can use the eyedropper to match a color in the image.

Tip 9: Saving Non-destructive Editing Styles

NDE, or non-destructive effects, are effects you can add to an object that can be turned on or off, rearranged etc. These are listed in the Properties docker, by clicking the FX tab. The swimsuit in this example has a few effects added, and you could click the plus sign to add more effects.

To save these effects as a style for use in other objects, right-click on the object and choose Object Styles > New Style from > Bitmap Effects. Assign the style a name, such as Fabric Effects.

The new style will now be listed in the Object Styles docker. The effects can be applied to other objects, either by dragging the style name onto an object, or by selecting the object first then double-clicking the style name.

To save this style for use in other documents, use the Export Style Sheet option.

Tip 10: Page Sorter View

For any multi-page document, you can choose View > Page Sorter View. This provides an at-a-glance look at all pages.

You can drag and drop to rearrange, and the context menu provides options for renaming, inserting, duplicating, etc.

From here, you can double-click the page you want to open.

See what's new in CorelDRAW Graphics Suite 2019!

Download your FREE 15-day trial for Windows or Mac and dare to design differently with new non-destructive effects, improved pixel workflow, and other professional graphics tools.

Related Tutorials

Share this post

Comments (2)

  • khan Reply

    nice info you are sharing thanks

    December 17, 2018 at 10:40 am
  • IMAD GUL Reply

    very nice tutorial in repeating our skills thanks to you very much!

    September 6, 2018 at 11:09 am

Leave a Reply

Your email address will not be published. Required fields are marked *


Sign-up for our newsletter

Sign-up for our newsletter

Get our latest tips, tutorials, and special offers sent weekly to your inbox!

You have Successfully Subscribed!

Pin It on Pinterest

Share This