How to Sync and Share Symbols

How to Sync and Share Symbols

In this tutorial, you’ll learn how to share, sync, and manage symbols with the Assets docker. You can create a single source of truth for design assets by sharing symbols across projects and with teams, and syncing updates when changes are made by you or others.

Note: asset management tools are available exclusively with a CorelDRAW Graphics Suite subscription or licensing with maintenance.

Thanks for watching! We hope you found this tutorial helpful and we would love to hear your feedback in the Comments section below. You will find a written version of this tutorial below, and a printable PDF copy to download on the Download Resources tab above.

In this tutorial, you’ll learn how to share, sync, and manage symbols with the Assets inspector. You can create a single source of truth for design assets by sharing symbols across projects and with teams, and syncing updates when changes are made by you or others.

Note: asset management tools are available exclusively with a CorelDRAW Graphics Suite subscription or licensing with maintenance.

Thanks for watching! We hope you found this tutorial helpful and we would love to hear your feedback in the Comments section below. You will find a written version of this tutorial below, and a printable PDF copy to download on the Download Resources tab above.

See what's new in CorelDRAW Graphics Suite 2021!

Download your FREE 15-day trial for Windows or Mac and fuel your creative fire with the new perspective tools, flexible design space, progressive photo editing tools, and much more.

Download these free resources:

Written tutorial for Windows (PDF, 465 KB)
Written tutorial for Mac (PDF, 431 KB)

CorelDRAW Graphics Suite Resources
Quick Start Guide (PDF, 2 MB)
Keyboard Shortcuts (PDF, 3.5 MB)
CorelDRAW User Guide (PDF, 28 MB)
PHOTO-PAINT User Guide (PDF, 26 MB)

Tools You Need

CorelDRAW Graphics Suite 2021

Fuel your creative fire with CorelDRAW Graphics Suite 2021: a complete suite of graphic design software for professional vector illustration, layout, photo editing and more.

Halloween Clipart

New for 2021! Create some spook-tacular Halloween creative projects with this collection of 320+ images, available in PNG and vector formats.

CorelDRAW Standard 2021

Dream it then design it with CorelDRAW Standard 2021, the go-to graphic design suite for hobbyists and home businesses.

Wacom One Creative Tablet

The Wacom One creative pen tablet offers a natural pen experience on a 13” screen, perfect for creatives seeking great value for their money.


How to Sync and Share Symbols with the Assets Docker

In this tutorial, you’ll learn how to share, sync, and manage symbols with the new Assets docker, previously known as the CONNECT Content docker. With the Assets docker you can create a single source of truth for design assets by sharing symbols with clients and team members. And when changes are made to an asset, it can be synched across any projects that use the asset. This makes it faster and easier to work in teams, and ensures you are always working with the most current assets.

NOTE: the Assets docker is available exclusively with a CorelDRAW Graphics Suite 2021 subscription or licensing with maintenance.

Click on any of the images below to view full-size.

What are Symbols?

CorelDRAW lets you create objects and save them as symbols. Symbols are defined once and can be referenced many times in a drawing. Each time you insert a symbol into a drawing, you create an instance of the symbol. For example, if you have a company logo that is frequently used when creating brochures, business cards, and other marketing materials, you can save the logo as a symbol.

Using symbols and creating symbol libraries are a great way to save a lot of time in the design process and reduce file size, especially if you have repeated use of the same symbol in your design files.

If you edit a symbol in a CorelDRAW file, it will automatically update all other instances of that symbol throughout the document, so you don’t need to update each object individually. And with the Assets docker, symbols can now be synched and updated across all documents that they are used in, even those created by others.

To learn more about symbols, watch our full tutorial Creating and Using Symbols.

Exploring the Assets Docker

To open the Assets docker, go to Window > Dockers > Assets. Under the search bar along the top there are 3 icons:

  • the Local and Network Assets icon (formerly the CONNECT docker) allows you to browse through all the assets available by content or category.
  • the Cloud Assets icon allows you to sign into the Cloud to download, upload, and share assets. The Cloud section contains all assets, including your own and those that have been shared with you.
  • the Linked Assets icon, which displays the assets you are using that have been linked to the Cloud.

There are so many benefits to asset management with the Assets docker as it allows you to share symbols through the Cloud with other designers.

For example, if you design a symbol or logo that other designers are also using and later decide to make changes, the other designers will be notified that there is an update available, and they can sync it to the “source of truth”.

Creating and Using Corel Symbol Library (CSL) Files

The symbols that you create in a drawing are saved with the CorelDRAW file. If you want to use the symbols in other drawings or share them with other users, you can save or export them to the Corel Symbol Library (CSL) format, creating a symbol library.

To create a symbol library, have a document open that contains the symbols you want included in the library. You can either use File > Save As and select the CSL – Corel Symbol Library file type in the Save as type list box, or you can click on the Options icon in the top right corner of the Symbols docker and select Export Library.

Once you have created a CSL file, you can also save it to the Cloud to share with other users. Click the Options icon again and select Save to Cloud. Then add your title, select the folder you want to save to and press Save.

 

Linking a CSL File to a Design File

Once you have saved your CSL file to the Cloud, you can now link it to your design documents.

  • open the document where you will be using your symbols
  • open the Assets docker
  • click on the Cloud icon and locate the CSL file you saved to the Cloud
  • right-click on the CSL file and select Link to Document

A dialog box will pop up telling us we can view and used the linked symbol library using the Symbols docker, and you can see a linked icon in the top right corner of the symbol image in the Assets docker.

You can access it by going to the Symbols docker, then clicking on Linked Symbols and selecting the CSL file that you just linked.

  • from here, drag and drop the symbols you want to use from the docker into your design file
  • in the Linked section of Assets docker you’ll see the CSL library you just linked

As we add symbols from the library to our document, we can now see whether or not it is linked below how many instances of the symbol there are in the document.

 

How to Edit an Existing Symbol

If you want to edit one of these symbols and change all instances of this symbol in your document to your new edited symbol, click on the Linked section in the Assets docker. Then right-click and select Edit to open the symbol library you saved to the Cloud.

In the drawing window, select the symbol you want to edit then click Edit Master.

Make any desired edits and then click Finish. To save the updated symbol to the cloud, go to File > Save. The edited symbol will be uploaded to the cloud and broadcast to any documents using this symbol.

If another user, such as a client or colleague, is using this symbol in another document, they can click on the Linked section of the Assets docker and they will see a red dot notification above the cloud, indicating that there has been an update to this symbol library.

They can sync the assets by right-clicking and selecting Sync linked assets.

Now all the instances of the symbol in their design file will be updated to reflect the edits you made.

NOTE: only the owner of a CSL file can edit it, or a user who has direct access, for example if it is on a shared network.

If you’re not an owner and want to edit the symbol, click on Break Link to make a linked symbol internal.

Then you can edit as before, by clicking Edit Master and editing the symbol as desired.

The Assets docker makes it easy to create a single source of truth for design assets by sharing symbols across projects and with teams, and syncing updates when changes are made by you or others.


See what's new in CorelDRAW Graphics Suite 2021!

Download your FREE 15-day trial for Windows or Mac and fuel your creative fire with the new perspective tools, flexible design space, progressive photo editing tools, and much more.

Related Tutorials

Share this post

Leave a Reply

Your email address will not be published. Required fields are marked *