How to Use Scripts

How to Use Scripts

Have you been struggling to turn your ordinary photos into professional-looking, dramatic shots? Sometimes it can be difficult to know which photo editing techniques to use, and how to use multiple techniques on one photo. You may eventually end up with the results you wanted, but only after considerable time spent. This is where scripts come in.

A script is like a mini-program that you can use on your photo to automatically apply a series of artistic effects or editing techniques to achieve some dramatic results. Using a script will take all the guess work out of it, and save you a lot of time, particularly if you want to apply the effect to a series of photos. This video tutorial will show you how fast and easy it is to work with scripts, and how you can achieve some amazing results in a matter of seconds.

PaintShop Pro allows you to choose from a selection of scripts that are included with the program. You can also create your own scripts or purchase pre-made scripts from the Discovery Center store or the Get More tab on the PaintShop Pro welcome screen.

Download resources:
Written tutorial (PDF, 1.09 MB)
FREE High Key Black and White script (Zip file, 156 KB)
Sample images (Zip file, 13.1 MB)

How to Use Scripts

In this tutorial, you will learn how to use scripts in PaintShop Pro. PaintShop Pro comes with many scripts that you can use, but you can also purchase more to add to your collection. For the examples used in this tutorial, the High Key Black and White script can be downloaded free from the tutorial page. The Colorized Sketch script and Soft Dream script can be purchased from the Discovery Center store or on the Get More tab in the PaintShop Pro in-product welcome book.

Click on any of the images below to view full-size.

Example 1: Simple “One-Click” Script

  • Open PaintShop Pro under the Edit tab with the photograph you want to run a script on.
  • Turn on the Script toolbar by going to View > Toolbars > Script.

  • Click on the dropdown menu to view the scripts you have available to run.
    • Choose the High Key Black White Script to run on this photograph of a dog.

  • Click the blue Run Selected Script button.

And just in a matter of seconds, we’ve transformed our image using this high key script to help get rid of the shadows and make the photo look brighter, and more professional.

Example 2: Interactive Scripts

In this second example, we’ll run an interactive script which requires some input as it runs. For this example, we’ll use the Colorized Sketch script that’s included in the Photo Sketch script bundle.

  • Select the Colorized Sketch from the dropdown menu of the Script toolbar.
  • Click the Run Script button to run the selected script.

The script will run but a few seconds in, it will require you to adjust the Threshold to your desired level.

  • Play around with this level until you see visible lines outlining the subject which will vary from photo to photo.
  • For this example, set the Threshold level to 250 and then press OK.

When the script finishes running, we’re left with a beautiful colorized sketch of this woman.

In the Layers palette, you can toggle the Visibility icon (eye) on the layer produced by the script on and off to view the difference between the original photograph and the colorized sketch.

  • At the top of the Layers palette, you can adjust the Opacity level of the layer: decreasing the opacity will allow more of the original photo to show through.
  • In this example, we adjusted the Opacity level to 55.

And now you’ll see the photograph has a bit more color filled in within the sketch!

Example 3: Adjusting Script Output

In our final example, you’ll learn how to make adjustments to the script output.  We’ll use the Soft Dream script.

  • Select the Soft Dream script from the dropdown menu.
  • Then click the Run Script icon.

After the script has finished running, you can see several layers have been created which we can make adjustments to.

The default script has added a soft dreamy-like quality to the landscape image with a light blue hue over top.

But we can make some adjustments and change the hue, so it better matches our image using the Flood Fill tool to fill the Filter layer with a new color.

  • Make sure the Filter layer is selected in the Layers palette.
  • Activate the Flood Fill tool.
  • Then choose your desired color from the Materials palette.
  • Click on the image to fill the Filter layer with your chosen color.

Experiment with as many colors as you’d like until you’re happy with the end result.

These are just a few ways you can easily enhance your photos and get creative with the click of a button using scripts!

Thanks for watching! We hope you found this tutorial helpful and we would love to hear your feedback in the Comments section below. And don’t forget to visit our social media pages and show us what you’ve learned by sharing your photos, videos and creative projects with us.

See what's new in PaintShop Pro 2020!

Download your FREE 30-day trial and check out the latest version of PaintShop Pro, with a new touch-ready workspace, SmartClone tool, Refine brush and enhanced text editing.


Related Tutorials


Tools You Need

PaintShop Pro 2020

Experience an all-in-one photo editor and graphic design software that will change the way you edit photos.

Glitch Effect Script for PaintShop Pro

With the Glitch Effect script, it’s easy to create the hot new image trend that has a distorted techno effect, reminiscent of old VHS tapes.

PaintShop Pro 2020 Ultimate

Get a faster, easier, more creative photo editor PLUS an exclusive bonus collection of premium software.

Split Tone Script Bundle

This collection of 5 split tone scripts for PaintShop Pro will add different colors to shadows and highlights in your photos for dramatic results!

Share this post

Comments (32)

  • mikeysoft Reply

    Ok, so you told me how to use the filmstrip script. There are a hundred sites with the same information. Don’t get me wrong; I know what a filmstrip is (I was running real filmstrips through a projector 60 years ago). But nothing in the tutorial or any of the other sites tutoring this particular skill tell me what I might want to do with my new creation. I saw one that suggested using it as a banner. Is it just a fancy end-to-end collection of photos that I could almost as easily assemble in MS Word? Does the script just produce a line of photos with a fancy frame around them? It seems like a needless new skill in software that is approaching the over-bloat stage. Corel should be making two versions: the professional version for those who don’t mind automating ridiculously mundane tasks, and the simple version for those of us who just want a tool that will produce professional quality results in order to get a job done.
    Thanks,
    Mike

    November 4, 2019 at 10:49 pm
  • Rob Maynard Reply

    This tutorial (both the video and written versions) are very frustrating because they seem to bear no reality to my newly purchased PSP 2019 – or am I doing something wrong?

    March 31, 2019 at 1:10 am
    • Adam Reply

      Hello Rob,

      This tutorial was created for PaintShop Pro X9, so you may encounter some differences in the interface! That said, File > Scripts is still a common method for accessing and running scripts. Is this the missing menu item? If so, you are likely running PSP 2019 in the Essentials workspace. You can switch to the Complete workspace by using File > Workspace and selecting Complete, which will add several items to menus throughout the program.

      Hope this helps,
      Discovery Center Team

      March 31, 2019 at 11:56 pm
    • Paul Shipley Reply

      @ Rob Maynard
      I had the workspace set as ‘Complete’ as described by Adam, but when I went to try out a script the folder was empty.
      I ended up doing the following:
      I went to the main installation folder
      C:\Program Files\Corel\Corel PaintShop Pro 2019 (64-bit)\Languages\EN
      and copied (right click, Copy) Scripts-trusted and Scripts-restricted folders and pasted them into
      yourusername\Documents\Corel PaintShop Pro\2019
      If you get a popup asking if you want to merge the folder click yes.
      The tutorial then should work as described despite being written for an earlier version
      HTH

      April 1, 2019 at 4:12 pm
      • Claire Reply

        Thank you, Paul! You have saved my sanity.

        July 27, 2019 at 7:00 am
  • Rob Callighan Reply

    hi downloaded the new update for x8 service pack 3. but cannot download the frr scrips. i keep getting this error Reference #50.4e6f648.1518854956.34aea4b any help please

    February 17, 2018 at 3:17 am
    • Adam Reply

      Hello Rob,

      Unfortunately PaintShop Pro X8 is no longer a supported product, and our technicians would be unable to assist with this. We would suggest taking a look at the Knowledgebase, where we keep the solutions to many previously resolved issues, or the User Forums to see if anyone in the community has had a similar problem and resolved it.

      Hope this helps!
      Discovery Center Team

      February 17, 2018 at 2:52 pm
    • Adam Reply

      Hello Rob,

      A quick update on that script pack! The DC team took a look around for it, and found a valid download link. You can access those scripts from this link:
      http://www.corel.com/akdlm/6763/downloads/IPP/paintshoppro/scripts/ExclusiveScriptSampleBundle.exe

      Best,
      Discovery Center Team

      April 5, 2018 at 11:49 pm
  • Mike Nelson Pedde Reply

    One quick note on the night script, including the moon. It’s not enough to duplicate the raster layer and place the ‘reflected’ moon in the water. You also need to flip vertical as reflections are always mirrored. 🙂

    Mike.

    November 3, 2017 at 6:38 pm
  • Susanne Reply

    Very well explained. Even for Dummies like me. Keep up the good work!

    September 15, 2017 at 5:16 am
  • Kimberly Reply

    I have been using this Corel paint shop pro for my page so far its got what I wanted done! Thankful to have this! It does a good job helping me turn my photos in to beautiful pictures.

    November 3, 2016 at 6:43 pm
  • Andrew Reply

    I can see that I’ll be using the tutorials a lot as they easy to understand.

    October 31, 2016 at 11:28 am
  • PauLS Reply

    Great tutorial! Very simple and easy to follow, the scripts are a great timesaver and the results quite spectacular. Thank you.

    October 21, 2016 at 4:34 pm
  • Julie Reply

    Great tutorial. I’m looking at purchasing X8 and I was wondering whether scripts made in older versions of PSP (such as PSP8) will still work in X8?

    August 7, 2016 at 12:00 pm
  • Carol Ryan Reply

    Enjoyed the tutorial. Now to put “scripts” to work.

    July 5, 2016 at 12:56 pm
  • Ingo Tillar Reply

    Ich habe über PSP X8 Skripte gekauft. Sie wurden auch im Programm runter geladen. Nur leider kann ich sie nirgendwo finden. Weiß jemand wo sie abgespeichert werden?

    July 2, 2016 at 6:25 am
    • Adam Reply

      Hello Ingo,

      Each script has an included PDF file with instructions on where to put them, so it is always good to check there to be sure. That said, the most common place to install scripts is the Scripts-Restricted folder.

      In a default PaintShop Pro X8 installation, that is found at C:\Users\YOURNAME\Documents\Corel PaintShop Pro\18.0\Scripts-Restricted

      Hope this helps!
      Corel Discovery Center Team

      July 4, 2016 at 1:17 pm
  • Joel S. Davis Reply

    I’d appreciate a tutorial on WRITING scripts.

    July 1, 2016 at 1:47 pm
  • Tom Reply

    All I need to do is Paint out Decals, Smart erase and Crop pictures of equipment. I may need to lighten or darken the photos. I had Microsoft Digital Image 10 and I really miss that it is not available for Windows 10. Can you do a Tutorial on what I ask?

    June 27, 2016 at 2:18 pm
    • Adam Reply

      Hello Tom,

      Thank you for the suggestion! We are always thinking about what tools and projects to feature next, and will be sure to consider these. In the meantime, here is a tutorial covering a few tools that can help with cropping, cloning, and otherwise making fine cuts to an image:
      https://learn.corel.com/tutorials/removing-unwanted-objects-from-photos/

      Hope this helps!
      Corel Discovery Center Team

      June 28, 2016 at 12:44 pm
  • Paul Reply

    love the Video, have a question? I am trying to restore some old pictures, and there is a haze on the photo, How can I remove the haze, in order to get the look I am seeking ?

    June 9, 2016 at 12:36 pm
    • Adam Reply

      Hello Paul,

      Tricky question! There are a few ways to help restore photographs, and often a number of different techniques are required in order to clean an older photo. We do have a tutorial on just this process though, which you can find here:
      https://learn.corel.com/tutorials/restore-old-photos/

      Hope this helps!
      Corel Discovery Center Team

      June 9, 2016 at 12:59 pm
  • Fran Reply

    Bought some scripts but don’t see any read me files. Have a script in my documents but how do I get to the save to Corel Pro 6 screen to that particular folder in it? Have the Antique Phot one that I am trying to get into my Coral.

    May 30, 2016 at 11:20 pm
    • Adam Reply

      Hello Fran,

      There is a PDF file inside the .zip folder that you downloaded called ‘Importing Scripts into PaintShop Pro’ which has all the details! Some scripts need to go to slightly different places, so it is important to read the importing instructions for each script you download.

      The Antique Painting Script is compatible with PaintShop Pro X6 and up, but depending on your version the script folder location is a little different. Here is where you need to put the Antique Painting Script:

      For PaintShop Pro X6: C:\Users\YOURNAME\Documents\Corel PaintShop Pro\16.0\Scripts-Restricted
      For PaintShop Pro X7: C:\Users\YOURNAME\Documents\Corel PaintShop Pro\17.0\Scripts-Restricted
      For PaintShop Pro X8: C:\Users\YOURNAME\Documents\Corel PaintShop Pro\18.0\Scripts-Restricted

      Once the script is added to the folder, you can launch PaintShop Pro and select View > Toolbars > Script to open the script toolbar. Once it is open, select the script in the dropdown, and press the Run Selected Script button (the blue triangle button) to run the script!

      June 1, 2016 at 12:40 pm
  • Maurice Goupil Reply

    Je demeure au Canada (ville de Québec) comment obtenir la version française des documents disponibles en français. Pourtant, Corel est une entreprise canadienne. Son siège social est à Ottawa !!!
    J’ai communiqué par CHAT et j’ai reçu des réponses traduites. Le site proposé dans la discussion me retourne sur un site en anglais.

    May 23, 2016 at 4:04 pm
  • Joni Reply

    Yes, your instructional video is very helpful and encouraging! SO much to do, the possibilities are endless and these scripts really help!! THANK YOU!

    May 17, 2016 at 4:22 pm
  • Rita Reply

    I downloaded the latest update a few weeks ago and now I have no toolbars and cannot access them. !@#$%^&*()_

    May 17, 2016 at 11:43 am
    • adampotter Reply

      Hello Rita,

      Not to worry, there’s an easy fix for this one – all we should need to do is tell PaintShop to reset your workspace to get those toolbars back. Just hold down shift while launching PaintShop Pro, and click OK on the confirmation box that appears. PSP might take a little longer to start up this time (because it has to restore the workspace first), but after that you should be all set!

      All the best,
      Corel Discovery Center Team

      May 17, 2016 at 11:59 am
  • Margaret Waugh Reply

    Margaret

    I have never used scripts before and found the tutorial very informative. Going to enjoy playing around with scripts.

    May 14, 2016 at 12:58 pm
  • Brenda Reply

    I learned a lot and thoroughly enjoyed this one… And I am having a couple small problems so this helped a lot!!! A lot of things are easy to figure out on your own, but some I definitely need help with. Thanks….

    May 6, 2016 at 5:39 am

Leave a Reply

Your email address will not be published. Required fields are marked *


Pin It on Pinterest

Share This
Get a FREE creative pack!

Get a FREE creative pack!

Sign up for our newsletter and get a free creative pack plus the latest tips, tutorials, and special offers in your inbox each week.

You have successfully subscribed! Check your inbox for your email confirmation and free creative content pack.