Opening and Importing Photos

Opening and Importing Photos

Opening and Importing Photos

In this tutorial, you’ll learn how to open and import your photos into PaintShop Pro.

So what is the difference between opening and importing? When you open a file, you are opening it “as is”, bringing in the content, characteristics and settings that were saved with the file. When importing a file, PaintShop Pro will bring content in from a hardware source such as a camera or scanner or even allow for a screen capture.

When scanning, depending on your scanner you may also have options to set the resolution, color mode, file format or other settings.

How to Open Photos

PaintShop Pro can open popular image files including JPEG, PNG and TIF but also other photo editing software formats like AI and PSD. You can view the full list of compatible image files here.

There are several ways you can open photos in PaintShop Pro:

From your Windows Desktop

  1. Drag the photo from your computer into PaintShop Pro or
  2. Right-click on the file on your computer and choose Open With > PaintShop Pro

TIP: You can associate specific file formats with PaintShop Pro, such as JPEG, TIF, or PNG, so that these files will open in PaintShop Pro when you double-click them from the Windows desktop.

  • Right-click on file on your computer, select Open With > Choose Another App.
  • Select PaintShop Pro and check Always use this app to open .jpg files and click OK.
  • Now you can just double-click on any JPG image on your desktop and it will automatically open in PaintShop Pro.

From within PaintShop Pro

  • File > Open or use the Open icon or Ctrl + O.

  • In the Look in drop-list, choose the folder where the file is stored.
  • Click the name of the file that you want to open. If you want to open multiple files, hold down Ctrl, and click the filenames.
  • Click Open.

To Open an Image from the Organizer Palette

  • In the Organizer palette, click the Show/Hide Navigation button to display the Navigation palette.
  • In the Navigation palette, click one of the following tabs:
    • Collections — displays a custom list of cataloged folders and a list of virtual collections

    • Computer — displays a list of all folders and devices on your computer
  • Double-click a folder to display the subfolders it contains.
  • Click the folder that contains the photos that you want, and drag the corresponding image thumbnail into the image window.

NOTE: If you are opening a RAW photo file, the Camera RAW Lab dialog box will open so you can adjust the settings that are stored with the RAW photo file.

To Open a Recent File

  • Go to File > Recent Files to choose from 10 files last opened.

TIP: 10 is the default number of recent files that will be listed. To change this:

  1. Choose File > Preferences > General Program Preferences.
  2. From the left pane, choose Miscellaneous.
  3. Type or set a value in the Recently used file list control.
  4. You must restart PaintShop Pro before the new settings take effect.

How to Import Photos

Manage Tab

After you transfer your photos to your computer (by using Windows or the software for your camera), you can import your photos into PaintShop Pro. You import photos by browsing to folders. The photos in the folders are then cataloged automatically in a database. This makes it easy to find, edit and update the information for your photos.

  1. In the Navigation palette, click the Collections tab, and click Browse More Folders.
  2. In the Browse For Folder dialog box, navigate to the folder you want.
  3. Click OK.

The folder is added to the folder list and all the images are cataloged in the application database.

Scanning Images into PaintShop Pro

Edit tab

  1. After installing the software that came with your scanner, connect your scanner to your computer.
  2. In PaintShop Pro, choose File > Import, and click From Scanner or Camera (WIA option) or TWAIN Acquire, depending on the type of scanner.
  3. Use the scanner’s software to perform the scan.

If you have set up your scanner to work with PaintShop Pro, the image is displayed in the application after it is processed. The scanner’s software may remain open, so you can either continue to acquire images or exit the software.

And it’s that simple to open, import, and scan images into PaintShop Pro!

Thanks for watching! We hope you found this tutorial helpful and we would love to hear your feedback in the Comments section below. And don’t forget to visit our social media pages and show us what you’ve learned by sharing your photos, videos and creative projects with us.

See what's new in PaintShop Pro 2021!

Download your FREE 30-day trial and discover a world full of creative possibilities with PaintShop Pro 2021, your all-in-one photo editing and design software.

Related Tutorials


Tools You Need

PaintShop Pro 2021

Discover a world full of creative possibilities with PaintShop Pro 2021, your all-in-one photo editing and design software.

Crushed Stone Mosaic Script

Now you can easily make your own mosaic images in seconds, using your photos and this PaintShop Pro script.

PaintShop Pro 2021 Ultimate

Enjoy a faster, easier, more creative photo editor PLUS an exclusive bonus collection of premium software.

Retro Warm Matte Scripts

Recreate a popular retro look with this collection of 5 PaintShop Pro scripts that will enhance the colors in your photos and add a matte effect finish.

Share this post

Leave a Reply

Your email address will not be published. Required fields are marked *


Get a FREE creative pack!

Get a FREE creative pack!

Sign up for our newsletter and get a free creative pack plus the latest tips, tutorials, and special offers in your inbox each week.

You have successfully subscribed! Check your inbox for your email confirmation and free creative content pack.